Selenium WebDriver 3.4.0 + geckodriver 0.18.0 + Firefox ?? - which combination works?

0
0

I’m running Selenium 2.x with Firefox 47.0.2 on Windows Server 2008R2 using .Net. I’m running x64 code.

I’m trying to upgrade to Selenium 3.40 + geckdriver 0.18.0 but I can’t find a version of Firefox that runs 100%. I’m using x64 en-US versions of Firefox unless otherwise noted. They were downloaded from here.

Here’s what I have found:

  • Firefox 51.0.1 – too old – Geckodriver complains “Unable to find a matching set of capabilities”
  • Firefox 52.0.2 – I get an IndexOutOfBoundException when calling setPageLoadTimeout
  • Firefox 52.2.1esr – I get an IndexOutOfBoundException when calling setPageLoadTimeout
  • Firefox 53.0.3 – upon exit, the Firefox window stays up, needs to be closed manually
  • Firefox 54.0.1 (tried both x64 and X86) – crashes upon exit
  • Firefox 55b9 – crashes upon exit

Is there a combination of selenium 3.4.0 + geckodriver + Firefox that works on .Net for you?

  • You must to post comments
0
0

This Question have been surfacing out quite often for sometime now since we migrated from the legacy Firefox releases to Marionette based Mozilla Firefox releases (beginning with Firefox 48).

In general, each GeckoDriver release supports each version of Mozilla Firefox releases (beginning with Firefox 48) where the property "marionette" needs to be set to true (either by default or through configuring through DesiredCapabilities Class and passing it as an argument while initializing the Web Browser)

If you are working with the legacy Firefox releases (till Firefox 47.x) GeckoDriver still works but you have to explicitly set the property "marionette" to false

Recently, some dependency were announced between GeckoDriver, Selenium and Mozilla Releases. The GeckoDriver Release Notes clearly states all the major/minor New Feature Addition, Enhancements,Bug Fixes and Download Location separately in this link.


Selenium Dependencies:

Selenium 3.4.0 now recommends Geckodriver v0.16.0 strongly.

Selenium 3.3.1 better supports Geckodriver v0.15.0.


GeckoDriver Dependencies:

geckodriver v0.18.0 now recommends Firefox 53 and greater

geckodriver v0.16.0 is only compatible with Selenium 3.4 and greater.


Answer:

Selenium 3.5.0 + GeckoDriver 0.18.0 + Firefox 55.0.2 combo works best at my end.


Last update was on : 22Aug2017

  • You must to post comments
Showing 1 result
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Website