Appium [iOS] Instruments crashed on startup

0
0

Maybe somebody can help me.

When appium tries to run application, the screen flashes with app splash screen, as if appium tries to launch app multiple times. This behaviour happens both on simulator and real device.

I set enable on my iOS devices UI Autimation, but when i try start inspector i have this problem:

info: [debug] [INST STDERR] 2015-11-05 15:11:05.082 instruments[1495:39489] WebKit Threading Violation - initial use of WebKit from a secondary thread.
info
: [debug] [INST STDERR] 2015-11-05 15:11:06.049 instruments[1495:39460] Attempting to change event horizon while disengage
error
: Failed to start an Appium session, err was: Error: Instruments crashed on startup
info
: [debug] [INST STDERR] 2015-11-05 15:11:06.049 instruments[1495:39462] Attempting to change event horizon while disengage
Instruments Trace Error : Target failed to run: Permission to debug com.myapp.iphone was denied. The app must be signed with a development identity (e.g. iOS Developer).
info
: [IOS_SYSLOG_ROW ] Nov 5 15:11:04 tests-iPod com.apple.xpc.launchd[1] (UIKitApplication:com.myapp.iphone[0xe163][607]) <Notice>: Service exited due to signal: Killed: 9
info
: [debug] [INSTSERVER] Instruments exited with code 253
info
: [debug] Killall instruments
info
: [debug] Instruments crashed on startup
info
: [debug] We exceeded the number of retries allowed for instruments to successfully start; failing launch
info
: [debug] Stopping iOS log capture
info
: [debug] Reset not set, not ending sim or cleaning up app state
info
: [debug] Cleaning up appium session
info
: [debug] Error: Instruments crashed on startup
at
[object Object].Instruments.onInstrumentsExit (/Applications/Appium.app/Contents/Resources/node_modules/appium/submodules/appium-instruments/lib/instruments.js:440:31)
at
[object Object].<anonymous> (/Applications/Appium.app/Contents/Resources/node_modules/appium/submodules/appium-instruments/lib/instruments.js:353:12)
at
ChildProcess.emit (events.js:110:17)
at
Process.ChildProcess._handle.onexit (child_process.js:1074:12)
info
: [debug] Responding to client with error: {"status":33,"value":{"message":"A new session could not be created. (Original error: Instruments crashed on startup)","origValue":"Instruments crashed on startup"},"sessionId":null
info
: <-- POST /wd/hub/session 500 33841.937 ms - 182}

Application is in form of .ipa

Thanks,
Best regards.

  • You must to post comments
0
0
Target failed to run: Permission to debug com.myapp.iphone was denied. 
The app must be signed with a development identity (e.g. iOS Developer).

You application should be signed with developers key. Click here for documentation

  • You must to post comments
Showing 1 result
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Website