Appium: adb server version (31) doesn't match this client (36) [duplicate]

0
0

This question already has an answer here:

Here is my problem, I’m running my Appium script with python instead of
py.test. I’m doing because py.test does not play nicely with variables I want to get from a text file. However, when I run my script with python everything works, except no matter what, my first method will always have an error. Does anyone know how to fix the error adb server version (31) doesn’t match this client (36)?

adb server version (32) doesn’t match this client (36); killing…” shell getprop ro.build.version.release’ exited with code 1{“stdout”:””,”stderr”:”error: device ‘adb server version (32) doesn’t match this client (36); killing…’ not found\n”,”code”:1}

  • You must to post comments
0
0

I fixed this by doing the following:

  1. going into GenyMotion settings -> ADB tab,
  2. instead of Use Genymotion Android tools (default), I chose Use custom Android SDK Tools and then browsed to my installed SDK.
  • You must to post comments
Showing 1 result
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Website